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Introduction  
Microsoft® Excel® for Mac 2011 (Excel 2011) delivers more functional compatibility across platforms, 
new and improved collaboration tools, and a more refined, familiar user interface. Excel 2011 makes it 
possible to analyze, manage, and share information with others in more ways than ever before, helping 
you make better, smarter decisions. With a more intuitive, modern appearance and new data analysis 
and visualization tools, you can create effective business or information materials that visually track and 

highlight important data trends and easily communicate your results through professional-looking 
charts and reports. 

You can also easily share your insights with others through Microsoft SharePoint® 2010 or your 
Windows Live® SkyDrive® account. Collaborate in new ways and edit a workbook simultaneously with 
others online and accomplish your most important tasks faster. Your information is never far away as 
you can access your files from almost any web browser.1  With Excel 2011 you can work when and 
where you choose. 

Whether you’re producing financial reports, managing personal expenses, collaborating with a team on 
school or work projects, Excel 2011 makes it easier to get what you need done faster, with more 
flexibility, and with professional results. 

§ Welcome to Excel 2011 — our most intuitive, powerful, and compatible version yet. 

1 Microsoft Office Web Apps require an appropriate device, Internet connection, supported Safari, 
Firefox, or Internet Explorer browser, and either SharePoint Foundation 2010 for enterprise or, for 
personal and small business use, a free Windows Live ID to save and access files via SkyDrive. There are 
some differences between the features of Office Web Apps and the Office 2011 applications. 
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Excel 2011 At-a-Glance 

Create incredible content 
Today, a spreadsheet application is used for a variety of tasks, such as statistical analysis, forecasting 
revenue, managing business and personal finances, and maintaining address lists or student records. 
Your needs may be increasing but there may be no need to outsource and hire a consultant to meet 
them. With Excel 2011, you can quickly create polished and professional work. We’ve added new data 

analysis and visualization capabilities and enhanced long-time favorites to help increase your 
productivity and gain insights, resulting in better decisions.  

Take a glance at how Excel 2011 is designed to give you the best productivity experience across 
platforms and help you create professional results more easily.  

Get easier access to the right tools, at the right time 

New and improved features can help you be more productive, but first you need to find them when 
you need them. Fortunately, Excel 2011 gives you familiar, intuitive tools that enable you to work the 
way you want. 

§ Access features more efficiently. The new ribbon in Excel 2011 puts the commands you need right 
at hand so that you can focus on the end product, not how to get there. Get exactly the tools you 
need, when you need them. 

§ Get started in a few simple clicks. The new Excel Workbook Gallery gives you easy, organized 

access to a wide range of professionally designed built-in and online templates, your own custom 
templates, and your recently opened workbooks.  

Communicate your results more clearly 

Excel 2011 delivers powerful new features to help you discover patterns or trends at-a-glance that can 
lead to more-informed decisions. Use new dynamic formatting and rich visualization features to call out 
the highs and lows of your data.  

§ Turn complexity into clarity. Get a quick visual summary of data using tiny charts that fit within a cell 

near its corresponding values with new Sparklines.  

§ Enhanced data analysis and rich visualization. Improved Conditional Formatting enables you to 

format your values with icon sets, data bars, and color scales, giving your workbooks a polished, 
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professional look and enhancing your ability to see patterns and trends in your data. Excel 2011 
also gives you new tools to help you manage and build your conditional formatting criteria faster 
than ever before. 

Powerful and easy-to-use analysis tools 

Whether at work or home, you need to be able to manipulate and analyze your information in a way 
that gives you new insight to make better decisions — and the quicker you can finish your task the 
better. Many refinements and performance improvements in Excel 2011 make it easier and faster for 
you to accomplish your work. 

§ Summarize and analyze your lists with less effort. New improvements to PivotTables and Excel 
Tables, (formerly called Lists), provide you with feature-rich tools to help you quickly display the 
relevant details and add a professional polish to your results. 

§ Filter and sort your data in new ways. Sort and filter by color or utilize multi-select filters and new 
quick filtering options to help you narrow down a large list in a few simple clicks.   

§ Create professional-looking charts with ease. The dramatically improved charting engine gives 
you increased performance and new formatting features help you effortlessly achieve your desired 

results faster and more intuitively.  

Save time and simplify your work 

No matter what type of workbooks you create, you want to focus on your content, not the tasks 

associated with creating and managing them. Excel 2011 delivers new and improved tools that simplify 
your tasks and save you time at every step.  

§ Format your workbooks more efficiently through Office themes and cell styles. Apply 
coordinating formatting, colors, fonts, and graphic effects throughout your workbook in just a few 
clicks. 

§ Add more color to your worksheets. The addition of 32-bit color palettes throughout Excel 

means you are no longer limited to a choice of 40 colors in your workbooks. Plus, those same color 
choices have been extended to your worksheet tabs. 

§ Microsoft Visual Basic for Applications (VBA) has returned!  Extend Excel functionality by 

recording or creating your own macros. Automate complex actions, repetitive tasks, or simplify 
complex formulas and create your own custom VBA functions. 
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§ Add polished and professional images to your workbooks. With new and improved picture 
editing tools and SmartArt® graphics you don't have to be a graphic designer or use 
additional photo-editing programs. 

Work more easily with others 
Sometimes you want to share your workbooks with friends or co-workers. At other times, you need to 

work together with a team on school or work projects. In either instance, you want to focus on what 
needs to be done and not worry about whether they work on Mac or Windows. Excel 2011 provides 
new and enhanced cross-platform collaboration tools to help you work on team projects or show your 
work to other people.  

Excel 2011 offers easy ways to bring people together and help increase work quality. New technologies 
help break down barriers so you can share and work together on workbooks, making you and your 
team more efficient and productive.  

§ Protect your worksheets with more flexibility. Improved sheet protection gives you more fine-
grained control over the modifications other users can make and enables Mac and Windows users 
to share workbooks more easily. 

§ Share information with others and across workbooks more easily. Create new cross-platform 

compatible workbooks by default and copy and paste dates between workbooks without worrying 
about 1900 and 1904 date systems. 

§ Enterprise-level workbook protection tools. Control access to your sensitive workbooks through 

Information Rights Management (IRM) and share secure workbooks more easily across 
platforms.   

Work how, when, and where you choose 
If your ideas, deadlines, and work emergencies don’t always conveniently occur when you are at your 

desk, you are certainly not alone. Fortunately, Excel 2011 gives you the power to get things done when 
and where you want. 

Get the information you need, when and how you want it. Now you can easily access your workbooks 
by taking the Excel experience with you and stay on top of your needs while you’re on the go. 
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§ Edit virtually anywhere. View and edit your workbooks in a web browser with Microsoft Excel 
Web App when you’re away from home, school, or your office. You can also simultaneously work 
with other people on the same workbook — even if they don’t have Excel installed.2 

§ Keep your workbooks readily accessible. Save your workbooks to a Windows Live SkyDrive 

folder or Microsoft SharePoint site without leaving Excel and access them from almost any web 
browser. 3 

Whether you are creating a simple list or a complex mission-critical financial model, or getting work 
completed on the run, Excel 2011 makes it easier to get what you need done more quickly, with more 
flexibility, and with better results. 

 

 
2 Requires SharePoint 2010 for enterprise use or, for personal and small business use, a free Windows Live ID to save and access files via SkyDrive. 

3 Saving to SharePoint from Excel 2011 requires SharePoint 2007 or later. 



 

Create incredible content 
New and improved tools give you the power to 
easily create professional-quality content and an 
updated, familiar environment helps you get 
started right away. Greatly enhanced cross-
platform compatibility enables you to work with 
confidence, knowing that the workbooks you 
create will look great when you share them with 
others who work on Mac or on Windows. 

Excel 2011: A Closer Look 
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Ribbon 
N

ew
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Locate the commands you need when you want them and where you want them. The new ribbon, 
available across the Microsoft Office for Mac 2011 applications, gives you easy access to more 
commands so you can focus on the end product rather than how to get there. 

Figure 1 - The r ibbon gives you famil iar and intuit ive tools to help you be more productive. 

The ribbon brings together features formerly spread across several locations, such as the Elements 
Gallery and Formatting Palette, to give you a streamlined and more flexible work experience. It’s 
designed to help you access the full range of features that Excel provides — so that you can get more 
done in less time. For example, Paste Special options are now at your fingertips on the Home tab. Click 

the arrow next to Paste and find frequently used Paste options that were previously tucked away in the 
Paste Special dialog box along with the newly added ability to paste your copied content as a picture.  

§ The standard tabs that you see on the ribbon are organized to display commands relevant to a 
given task, so that you can access what you need more quickly.  

§ The ribbon also provides contextual tabs to give you the right tools you need, when you need 

them. For example, when you click a chart, additional contextual tabs will appear on the ribbon, as 
shown in Figure 2, with a broad range of additional chart options. 
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Figure 2 - When you select a chart ,  the Chart Layout and Format tabs also become avai lable to give 
you central ized, s impl i f ied access to the chart edit ing tools you need. 

Quick Tips:  

§ Double-click any tab name (such as Home or Layout) to minimize or expand the ribbon. Or, click the   
or button on the right edge of the ribbon, to minimize or expand the ribbon.  

§ Easily change the order of the ribbon tabs and make it your own. Click the gear button  located to 
the far right of the ribbon, and then click Customize Ribbon Tab Order. While in the Customize mode, 
simply drag and drop a ribbon tab to a new location. When you’re finished making your revisions, click 
the Done button. 

§ The ribbon is 
designed to give 
you fast, familiar, 
and easier access to 
more features — not 
to make you change the way 
you work. With that in mind, 
Office for Mac 2011 still 
provides the menus and core 
toolbars that you may know 
from earlier versions.  
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Excel Workbook Gallery 
N
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Whether you’re a large corporation, small business owner, non-profit organization, or looking for 
efficient ways to manage your personal information, with Excel 2011 there are a variety of templates in 
the Excel Workbook Gallery to help get you started. From time management and business essentials to 
personal and business finance, Excel helps you quickly create professional-looking workbooks. 

Figure 3 - Your custom, bui l t- in and onl ine templates and your recently used workbooks are al l  
accessible from a s impli f ied view. 
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Quick Tips:  

§ Keyboard users can press COMMAND + SHIFT + P to access the Excel Workbook Gallery.  

§ By default, the Excel Workbook Gallery automatically displays when Excel starts. To start Excel and 
automatically display a new workbook, simply click the Don’t show this when starting Excel check box at 
the bottom.  

§ Template thumbnails too tiny? Use the Zoom slider at the bottom of the Excel Workbook Gallery to 
quickly increase the size of thumbnails so you can view more details. You can also customize your view 
with buttons to show or hide recent workbooks and the rightmost pane, as shown here.  

 

§ Multiple sheet preview. If a template has multiple worksheets, you can view them right from the 

Excel Workbook Gallery. Move your mouse pointer from left to right over the thumbnails of built-in 
templates for a quick preview of other sheets or select a template and use the navigation options 
in the rightmost pane to navigate the previews.  

§ Download online templates without leaving Excel. Access the full range of Excel templates that are 

hosted online by Microsoft, both professionally-designed and community-submitted content. 
Browse online content by category, search by keyword, and then create your workbook with just a 
couple of clicks — no browsers or third-party tools required. 

§ Get quick access to your recently used files. View your recent workbooks by date, along with an 
indicator of how many workbooks are available for each date range. 
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Embedded Formula Bar 
N
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Quick Tip: Need a larger Formula Bar? Click the Expand button, located to the far right 
of the Formula Bar, or manually resize it so you can easily view those longer formulas, as 

shown in Figure 4. 

Formula Bar is no exception when it comes to giving you easier access to the tools you need at the 
right time. In Excel 2011, the new embedded Formula Bar is located in an easy-to-reach location below 
the ribbon and above the column headings of your worksheet. 

§ Work more seamlessly across multiple workbook windows. Each workbook window has its own 
independent Formula Bar so you can build formulas more easily, or quickly compare formulas 
between workbooks. 

Figure 4 - The new embedded Formula Bar is now closer to your work without covering your 
content. 
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Find System 
N
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Quickly locating information in your workbooks has never been easier. The new Find System, located 
on the right edge of the Standard toolbar, enables you to quickly search the current worksheet or your 
entire workbook. Similar to the Find dialog, you can search for text or numbers and include wildcard 

characters to fine-tune your search results. 

Quick Tip: Use the keyboard to quickly navigate between your next and previous 
search result. After you type your search string, press RETURN to navigate to the next 

search string. For the previous search string, press SHIFT + RETURN. 

Figure 5 – Search your entire workbook r ight from the main Excel window. 
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Media Browser 
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Quick Tips:  

§ If you have an audio or movie file selected, click the play button beside the search box to play the 
selected object without leaving the Media Browser. 

§ Right-click (or hold the CONTROL key and click) objects in the Media Browser for additional options, such 
as to open an image in iPhoto or to copy a shape, Clip Art image, or symbol. 

Excel isn’t just for numbers and lists of text any more. The Media Browser that you know from many 
Mac programs is available across Office for Mac 2011, giving you a more direct route to all the media 
you need in your workbooks from one centralized, searchable pane. The Media Browser combines 

objects formerly available from the object palette of the Toolbox with access to your media folders and 
libraries. Just drag to insert photos, audio, or movies as well as a wide selection of Clip Art, shapes, and 
the full library of symbol characters. 

§ All of your media at your fingertips. Access your 
iPhoto libraries and iTunes playlists directly from the 
Photos and Audio tabs. You can also access movies 
and iMovie projects that you save to the Movies 
folder right from the Movies tab.4 

§ Need to adjust the previews? Simply drag the zoom 

slider in the browser to customize your view for larger 
previews or to view more objects at one time. 

Figure 6 - Easi ly f ind and insert photos, Cl ip Art ,  
symbols,  shapes, and more from the new and 
improved Media Browser in Excel for Mac 2011. 

4 The Media Browser supports iPhoto 5 libraries or later, iTunes 6 playlists or later, and iMovie 3 projects or later. 
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Sparklines 
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Sometimes, numbers speak for themselves. At other times, charts or graphs can significantly clarify your 
information. With Excel 2011, you can take advantage of charts that use considerably less space than a 
traditional column or pie chart. Sparklines are small charts in a worksheet that provide a clear and 
compact visual representation of your data for quick and easy reference. 

Figure 7 – Create Sparkl ines for large amounts of data to provide an easy-to-read summary. 

§ View the details with at-a-glance analysis. Use Sparklines to show trends in a series of values, such 
as seasonal increases, the price of your home, or your monthly expenditures.  

§ Bring more visibility to your values. Highlight maximum or minimum values and increase impact by 

positioning a Sparkline next to its corresponding data. 

§ Greater compatibility. Excel 2010 for Windows also supports Sparklines, making it easy to share 
workbooks across platforms. 
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Quick Tips: 

§ It’s easy to create Sparklines: Select the values for your Sparklines, on the Charts tab, in the Insert 
Sparklines group, choose the type of Sparkline you want: Line, Column, or Win/Loss. 

§ Similar to a pie, column, or other chart type, when you select a Sparkline the corresponding data is 
highlighted, making it easy to visually connect the Sparkline to its source values.   

§ To format a Sparkline independently of a Sparkline group, select the Sparkline and on the Sparklines tab, 
in the Edit group, click Ungroup. 
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Conditional Formatting 
Im

pr
ov

ed
! 

Conditional formatting comes with even greater flexibility in Excel 2011 to help you more easily 
discover and illustrate important trends, highlight data exceptions, and maintain compatibility with Excel 
2007 and Excel 2010 for Windows. Best of all, you’re no longer limited to three conditional formatting 
rules and one conditional format per cell. With a limitation that exceeds 32,000 conditional formats, 
you’re essentially limited only by system memory. 

Figure 8 - Use condit ional formatt ing with data bars and icon sets to better analyze and emphasize 
your data. 

§ Distinguish trends more easily and gain insight. Add data bars with gradient or solid fills and 
visually see how one value compares to the others or identify trends. Data bars are drawn 
proportionally according to their values, negative values are clearly displayed, and zero values are 
suppressed.  

§ Use icons to classify your information. Icon sets help you visually identify the highs and lows in a 

range for faster analysis. Select from the available icon sets in the gallery or customize them to 
meet your needs. Mix and match icons from different sets or hide an icon for cells that meet a 

specified condition.  

§ Build your conditions faster. New conditional formatting options help you build criteria for your 

conditional formatting rules in a few simple clicks. Identify duplicate or unique values and add date 
criteria with no need to create your own formulas. 
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Quick Tips:  

§ It’s easy to modify the formatting for your icons and data bars or the way Excel 2011 computes the values 
for the highest, lowest, or midpoint values. To do this, on the Home tab, click Conditional Formatting, 
point to any of the available options, such as Data Bars or Icon Sets, and then click More Rules.  

§ You can now modify the precedence in which rules are applied in the Manage Rules dialog box. To do 
this, use the Move Up and Move Down buttons to change your rule order — there’s no need to recreate 
your rules.  

§ The newly added ability to reference other worksheets in your conditional formatting rules also extends to 
your Data Validation rules. 

§ Get easier access to your conditional formatting rules. The new Rules Manager, shown in Figure 9, 

enables you to quickly switch to other conditional formatting rules in your workbook so you can 
modify, add, or delete your rules in a single, simplified view. 

§ Reference other worksheets. In Excel 2011, you can now include references to other worksheets in 
your conditional formatting rules. 

Figure 9 – On the Home tab, c l ick Condit ional Formatt ing and then cl ick Manage Rules to access 
the new condit ional formatt ing Rules Manager. 
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Excel Tables 
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Tables in Excel 2011, previously known as Lists, are easier to create and enable you to format and 
analyze your data in new ways. Simply place your cell pointer in the range of cells you want to use as a 
table and on the Tables tab, select a table style from the gallery. Excel 2011 applies the table style to 
your data, automatically labels column headings, and adds Filters, called AutoFilters in previous 
versions, that provide quick sorting and filtering options.  

§ Change the look of your table at any time. Select another built-in table style that matches your 
active workbook theme or create a custom a table style to fit your needs. Apply other table 
formatting options, such as options to enhance alternating rows and columns or format the first or 

last column to help identify your key information in a few simple clicks. 

Figure 10 – The avai lable Table Styles automatical ly ref lect your act ive workbook Off ice theme and 
give you a wide variety of coordinated formatt ing options. 
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Quick Tips:  

§ Quickly add new rows at the end of your Excel table when using a Total row. Place your cell pointer in the 
last cell of your table above the Total row and press the TAB key. Excel will insert a new table row and 
automatically expand the table.  

§ Excel tables support structured references that use table names in a formula to make your formulas more 
meaningful and to maintain compatibility with Excel 2007 and Excel 2010 for Windows.  

§ For example, instead of using a formula with cell references such as =SUM(B2:G2) and manually filling it 
down a column, you can use =SUM([MonthlySales[@[Fantasy]:[Sports]]), shown in the formula bar in 
Figure 11, and Excel will automatically fill it through the corresponding cells in your table.  

§ While you’re checking out the new Tables tab in Excel, be sure to note the new Remove Duplicates 
feature that enables you to quickly generate a list of unique values in your table. Check for duplicates 
across your table fields or a single field — the choice is up to you.  

§ Your header row won’t scroll out of sight. Table headers replace regular worksheet headers at the 

top of columns when you scroll down in a long table, as shown in Figure 11. 

Figure 11 – Table headers scrol l  with your table regardless of the table locat ion on your worksheet 
— there’s no need to freeze your panes. 
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PivotTables 
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Figure 12 – When your cel l  pointer is in a PivotTable, the PivotTable Bui lder and the PivotTable tab 
automatical ly display, giv ing you quick and easy access to al l  the tools you need to modify and 
format your PivotTable. 

PivotTables are easier to use and more cross-platform compatible in Excel 2011. Along with new and 
improved features that enable you to sort and filter directly in a PivotTable, these additional 
enhancements will help you summarize and format your PivotTables and more: 

§ Automatic PivotTable creation. Turn a data range into a PivotTable and start taking advantage of 
the new features in a single click.  

§ New PivotTable Builder. The PivotTable Builder replaces the PivotTable Wizard in previous versions 

and provides a more streamlined method for building or modifying your PivotTable. Add fields to 
your PivotTable, change the hierarchy, calculation, or number format — all from a centralized and 
more intuitive location. 
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Quick Tips:  

§ Save time when creating a custom PivotTable style. Start with a built-in PivotTable style that’s close to your 
desired result and customize it to meet your needs. Right-click (or hold the CONTROL key and click) the 
PivotTable Style you wish to copy and then click Duplicate.  

§ For tips on how to use several of the new PivotTable features listed above, see the tip titled Explore new 
PivotTable features in the Insider Tips & Tricks section of this guide. 

§ Display only the relevant details. Expand or collapse specific portions of your PivotTable through 

new drill-down triangles that enable you to reveal details for select groups while showing only the 
subtotals for other groups. For example, in Figure 12, only the groups with the highest and lowest 
totals are expanded for a more detailed analysis. 

§ Conditional formatting support. Add data bars, icons, and other newly added conditional 

formatting features to your PivotTables for even more visual analysis. For example, in Figure 12 the 
conditional formatting icons make it easy to spot the group with the highest total and the group 
with the lowest total. The highest total is identified by the green upward pointing arrow and the red 
downward pointing arrow identifies the lowest total.  

§ PivotTable Styles. Easily change the look of your PivotTable report using a gallery of over 80 built-in 
PivotTable styles that are coordinated to match your active workbook theme. Like Excel table styles, 

PivotTable styles also provide options to quickly enhance alternating rows and columns. 

§ New PivotTable report designs and layouts. In a few simple clicks, add totals, subtotals, or switch to 

a compact, outline, or tabular layout to make your PivotTable report more readable and 
presentable. 
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Sorting and filtering 
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Sorting and filtering are two of the most basic tasks when working with large worksheets. In Excel 2011, 
these features have been dramatically improved and aligned to the sorting and filtering options found 
in Excel 2007 and Excel 2010 for Windows. New options for sorting and filtering make it easy to quickly 

find what you need without endlessly sifting through large data sets. Here are some of the new 
additions and compatibility improvements: 

§ Multi-select filter conditions. Select any number of items for display in your filters without needing 
to use a custom or advanced filter. 

§ More filtering and sorting flexibility. Enhanced Sort and Filter options go beyond sorting and 

filtering text and numbers. Sort or filter on cell color, font color, or even cell icons if your cells utilize 
new conditional formatting icon sets.  

§ Built-in filters for faster analysis. Excel 2011 offers quick filters for specific data types and makes 

filtering even more flexible. For example when filtering dates, you can filter by date periods such as 
Today, Tomorrow, Quarter, Month, or This Year, and when working with values, you’ll see choices 
such as Bottom 10, Above Average, or Below Average.  

§ Instant search for your filter. Start by typing your search term in the new Search Filter, shown in 

Figure 13 and relevant items instantly display. Narrow your results even further by deselecting 
those items you do not wish to display. 

§ More sorting levels and new management tools. The new Sort dialog box enables you to add 

more than 50 sorting levels and easily modify the sort precedence using drag and drop. 
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Figure 13 – The new Search Fi l ter provides instant search for your f i l ters.  
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Excel 2011 brings you improved chart performance and charting tools. Along with a dramatically faster 
charting engine (described later in this guide), new quick formatting options have been added to 
simplify charting and help you achieve more professional-looking results.  

§ Modify the entire look of your chart right from the ribbon. Use the Chart Quick Layouts gallery on 
the Charts tab and in a few simple clicks you can display a data table, add major and minor 
gridlines, or add labels and percentages on a pie chart. Or, start with a Chart Quick Layout and use 
the Chart Layout tab to quickly adjust specific settings, such as chart and axis titles, legend 
placement, data labels, or trendlines, and easily create the right chart for your data. 

Quick Tips:  

§ The improved charting engine is shared across Office 2011 which means you can use the same improved 
charting tools found in Excel when you create charts in Word 2011 or PowerPoint® 2011. 

§ Save your chart customizations as a chart template for easy reuse across your workbooks or even Word 
and PowerPoint 2011. To do this, on the Charts tab, in the Change Chart Type group, click Other, and 
then at the bottom click Save as Template. 

Figure 14 - Modify your chart layout or color and customize other chart elements from the Charts 
tab, Chart Layout tab, and Format tab in a few s imple cl icks.  
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Another goal for Excel 2011 was to improve even further upon the already highly accurate functions in 
our function library. We’ve designed new algorithms to help improve over 45 statistical, financial, and 
mathematical functions and to provide increased compatibility with Excel 2010 for Windows.  

§ More consistent names and new functions. Functions have been renamed to more accurately 
reflect what they do and new versions of functions better align with statistical, industry, and 
scientific definitions. For example, in Excel 2011 PERCENTILE.INC was added to have better 
consistency with industry expectations. 

§ Accurate by default. When a workbook created in a previous version is opened in Excel 2011, all 

functions that were updated in Excel 2011 will recalculate with the new algorithms. 

§ Compatibility functions. Older versions of the functions are still available to maintain compatibility 

with previous versions of Excel. When using Formula AutoComplete you’ll see them listed under 
the Compatibly Functions heading as shown in Figure 15. 

Figure 15 – Easi ly identi fy compatibi l i ty funct ions when using Formula AutoComplete. 
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Streamlined performance 
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Work more quickly and efficiently with enhanced performance for many of your favorite, familiar 

features in Excel 2011. See improvements from the moment you start Excel — from faster application 
launch and opening and saving files to calculating and drawing charts faster, large workbooks won’t 
slow you down. 

§ Take creating a scatter chart with 10,000 data points for example. In Excel 2008, you’d see a delay 
as Excel generates the chart. When installed on the same exact computer, with Excel 2011, the 
improved charting engine enables you to create the same chart with 10,000 data points almost 
instantaneously.  

How did we do it? We improved core functionality to make better use of your available Mac processing 
power to maximize performance on the hardware you already own. 
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Office themes 
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Office themes have been extended beyond charts, SmartArt graphics, and shapes in Excel 2011. Now 
you can you add professional and consistent formatting across your workbook or across multiple 
workbooks. And since Office themes are shared with Word and PowerPoint, it’s easier than ever to 
create coordinating Office documents. Simply select the Office theme you want and Excel 2011 does 
the rest. 

Figure 16 – Access theme elements on the Home tab. Start with a bui l t- in Off ice theme and then 
customize the look by choosing your preferred theme font or theme color set . 
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Quick Tip: It’s easy to create theme-enabled workbooks. When you choose your 
formatting options, select colors from the Theme Colors palette and use the Theme Fonts 

from the top of the Font list, labeled (Theme Headings) and (Theme Body). For more 
information on how to create theme-enabled workbooks or how to create a custom 

theme, see the Insider Tips & Tricks section of this guide. 

§ Faster formatting with little effort. Text, Excel tables, PivotTables, charts, SmartArt graphics, and 

drawing objects all change to reflect the theme you have selected, helping ensure that all elements 
in your workbook complement one another and have a consistent, professional look in a few 
simple clicks.  

§ Predefine your formatting preferences. When you add new content, such as a shape, diagram, or 
chart, Excel 2011 will automatically match them to your chosen Office theme. 
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Cell styles 
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New out-of-the box cell styles make formatting a breeze. When combined with themes, cell styles help 
you obtain even more consistent and easy-to-apply formatting throughout your workbook. In a few 

simple clicks you can add formats, such as font color, shading, and borders to your cells, without the 
need to memorize the changes you’ve made (or to copy and paste formatting in order to apply the 
same formats elsewhere). Best of all, if you modify the cell style your formatting will automatically 
update everywhere it’s applied in your workbook. In addition, most of the styles are theme-enabled 
which means if you modify your workbook theme your cell formatting will automatically update. 

Quick Tip: Quickly create a new cell style based on an existing style or modify a cell style 
to fit your needs. To do this, right-click (or hold the CONTROL key and click) the style, and 

then choose Modify or Duplicate. 

F igure 17 – Choose from a 
wide select ion of cel l  sty les 
and save t ime formatt ing. 
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32-bit color palette 
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Excel 2011 has broken out of the 40 color limitation for color palettes on all features that support color 
and now your color choices are almost infinite. Along with the ability to change your theme colors, you 
can also add up to 150 colors to the Apple Color Picker for easy reuse across your workbooks. 

Quick Tip: When working with Charts and Office Art, such as shapes and SmartArt 
graphics, custom colors are automatically added to the Recent Colors palette for these 

features and are saved with the workbook. 

Figure 18 – Access the 
Apple Color Picker from 
al l  color palettes in Excel 
2011. 
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Colored sheet tabs 
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Easily identify worksheets that are related through colored sheet tabs. For example if you have multiple 
worksheets that contain quarterly expenses and income, you can add visual organization by changing 
all of the worksheet tabs with expense information to one color and the worksheet tabs with income to 
another color. 

Quick Tip: Sheet tab colors are also theme-enabled. Simply select your tab color from 
the Theme Color palette and if you change your workbook theme the sheet tab color will 

automatically update. 

Figure 19 – To change your sheet tab color,  r ight-cl ick (or hold the CONTROL key and cl ick) a sheet 
tab and then cl ick Tab Color.  
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Visual Basic for Applications (VBA) 
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VBA returns to Office for Mac 2011, along with the Macro Recorder, and adds more cross-platform 
compatibility than previous versions. Create custom functions or automate complex or multi-stepped 
tasks to get your work done even faster. For example, if you have complex function you can create a 
simplified version and use it throughout your workbook and save valuable time. 

Quick Tips:  

§ Experienced VBA users can take advantage of enhancements in the object model, including support for 
new features such as Sparklines, as well as several tools in the Visual Basic Editor that are new to Office for 
Mac, including the Watch Window (with the ability to set Watch Points), the Locals Window, access to 
software updates, and IntelliSense® (AutoComplete). To access the VBA tools, on the Excel menu, click 
Preferences, click Ribbon, scroll to the bottom of the available tabs and then select Developer.  

§ If you’re an advanced user of any version of Microsoft Office, you might be amazed at how familiar VBA 
language will seem and how easy it is to learn to use. Explore the new VBA developer center at 
http://iheartmacros.com to help get started. The resources there focus on Office for Windows but most of 
them apply equally to Office for Mac. Also, check out the Insider Tips & Tricks in this guide for an overview 
of how to create your own custom function. 

http://iheartmacros.com
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Help 
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Get started right away with video tutorials, take self-paced, easy-to-follow online tutorials, and access a 
wide range of help resources from one centralized online location. Office for Mac 2011 gives you more 
choices for fast answers that make it easy to get started or to take your work in Excel to a new level. 

§ The welcome screen you see when you first start Excel 2011, shown below in Figure 20, gives you 
one-click access to online video tutorials on a range of topics. 

§ Also on the Help menu, click Get Started with Excel to open an online site where you can access a 

wide range of resources.  

§ Or, click Excel Help for the familiar Excel help dialog box and the option to go online to explore the 

full range of help videos, self-paced tutorials and more. 

Quick Tip: Did you know that you can get answers to your Office for Mac questions from your peers, experts 
who volunteer their time, and folks on the Office for Mac product team? Check out the Office for Mac forums 
and search to see if someone else has already asked your question or post a question yourself. You can also 

check out the Office for Mac blog, where the product team frequently posts tips, tricks, and information about 
new and interesting features. Access both the forums and the blog from http://microsoft.com/mac. 

Figure 20 - On the Help menu, just c l ick Welcome to Excel to access this window at any t ime. 

http://microsoft.com/mac
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Open and Repair 
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Encountering a corrupt or damaged workbook is not only frustrating; it also results in lost time. 

Fortunately, in Excel 2011, the newly added Open and Repair feature will automatically attempt to 
repair a damaged file, as shown in Figure 21, instead of refusing to open it. 

F igure 21 – The new Open and Repair feature helps you recover damaged or corrupt workbooks. 
No third-party ut i l i t ies required. 
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Picture Editing tools and SmartArt graphics 
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Excel isn’t always about the numbers. Dynamic graphics communicate ideas and help illustrate your 
data. New SmartArt graphic layouts provide you with even more flexibility to create intuitive diagrams 
and new and improved picture editing tools enable you to easily modify your images so you can be 
your own graphic artist and create incredible content. 

Figure 22 - SmartArt graphics help you create pol ished and s leek diagrams. 

1

§ Create professional-quality diagrams as easily as typing a bulleted list. Office for Mac 2011 adds 

dozens of additional SmartArt layouts for even more choices to help you convey related ideas and 
non-linear concepts with greater visual impact. Additionally, explore improved tools for working 
with picture diagrams and the ability to convert SmartArt diagrams to shapes.  

§ Perfect your pictures in a few simple clicks. Choose from a gallery of picture corrections to sharpen 

and soften photos in your workbooks or use a color wash to enhance them. You can even add an 
artistic flair by adding filters such as photocopy, marker, line drawing, glass, pastels and more. 
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Quick Tips:  

§ When you insert a SmartArt graphic, a text pane automatically appears. Type in that text pane, or directly 
in your SmartArt graphic, to populate shapes in your graphic with text, press RETURN to add new shapes, 
and use the TAB and SHIFT + TAB keys to promote or demote shapes or text within shapes. 

§ The new Remove Background tool works intuitively, automatically adding or removing image elements 
when you drag your mouse pointer over part of the picture. When this feature is enabled, just drag your 
mouse pointer straight across the portion of the picture you want to add or remove from the image. 

2

§ Display the perfect picture every time. With improved cropping, you see the entire image and you 

can drag to display exactly what you want within the image area. Or use the new Crop to Fit and 
Crop to Fill options and obtain greater cropping flexibility when using a picture cropped to a 
specific shape.  

§ Focus on foreground, not the background. A new Remove Background tool makes editing photos 

a snap right within Excel 2011. 

Note: The same new and improved picture editing tools are also available in PowerPoint 2011 and 
Word 2011. 
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Compress pictures 
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Reduce file size for easier sharing with the new compress pictures functionality. This feature (also 
available in Word 2011 and PowerPoint 2011) enables you to compress a selected image or all images 
in the file and provides a range of picture quality options for compression. 

Figure 23: To access picture 
compression options, on the 
Fi le menu cl ick Reduce Fi le 
Size. 



 

Work more easily with others 
When you need to work with other people, you 
shouldn’t have to worry about whether they work 
on Mac or Windows, or how you’re going to 
share and manage your project. Fortunately, 
Office for Mac 2011 takes care of those details for 
you with seamless cross-platform collaboration 
tools that help you get exactly the results you 
want every time. 
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Sheet protection 
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More flexibility and cross-platform compatibility is now available when protecting your worksheets in 
Excel 2011. In previous versions, worksheet protection is limited to protecting an entire cell, objects, and 
scenarios. Excel 2011 gives you the same protection options as Excel for Windows, such as the ability to 
lock the contents of a cell but give other users the ability to modify formatting, sort and filter, insert 
rows and columns in a worksheet, and more. 

Figure 24 – Access sheet 
protect ion options on the 
Review tab, in the Protect ion 
group. 

Quick Tip: When you turn off the ability to select locked cells, the RETURN or TAB key 
will only navigate between the unlocked cells, making it easier for other users to 

determine which cells they can edit. 
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1900/1904 date system 
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Excel 2011 gives you even more compatibility and flexibility across platforms by making it easier than 
ever to work between the 1900 and 1904 date systems.  

§ 1900 date system by default. New workbooks automatically default to the 1900 date system, 
making it easier for you to create more compatible workbooks.  

§ Copy and paste dates between workbooks on your terms — no manual correction required. Now 

when you copy content that contains dates between workbooks that use a different date system, 
instead of automatically shifting the dates by four years and one day, you’ll be notified so you can 
decide which date system to use, as shown in Figure 25. 

Figure 25 – Get instant 
noti f icat ion when two 
dif ferent date systems 
are encountered. 

Quick Tip: Not sure if you want to convert dates when pasting? If you want to keep 
your date values then allow Excel to make the conversion for you. It will automatically 

add or subtract four years and one day as needed so your pasted dates will display just 
as you see them in the source workbook. 
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Information Rights Management 
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Information Rights Management is now available on the Mac platform and enables Windows and Mac 
users to share secure Office documents more easily. Protect your files from unauthorized access and 
distribution and enforce those restrictions even if that file leaves your company’s secure network.5  

§ Set permissions for users, or groups of users, and identify who can read the file as well as whether 
they can print, forward, edit, or copy its contents.  

§ Predefined permissions. Your system administrator can create custom permissions that are 

company specific, ranging from any combination of the available options to specifying permissions 
by group, making it easy for you to select exactly the permissions you need. 

5 Creating IRM-protected documents with Office for Mac 2011 requires the volume license edition of Office 2011, as well as a Rights 
Management server running Windows Server 2008 R2 SP1. Opening IRM-protected content to which you have been given access can be done 
from any edition of Office for Mac 2011 or from Office for Windows 2003 or later. 

F igure 26 – Access IRM permiss ions on the Review tab in the Protect ion group.  



Work how, when, and where you 
choose 
It’s easy to create great content when you can 
work when and where you choose, and work 
seamlessly with others regardless of the tools 
they use. 
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When you want to leave your computer behind or need easy, shareable tools for collaborating with 
others, do you have what you need to get things done easily and effectively? Now you do.  

§ Save your Excel workbooks online and then access, edit, and even co-author workbooks from 
virtually any computer with an Internet connection.6 View your files in high-fidelity and edit them 
with confidence, knowing that your content will be preserved and your data retained even though 
you edited the file online. Now you can stay up to the minute with all the information you want 
when you want it.  

§ Extended editing, no new knowledge required. Perform light editing in your workbooks using the 

familiar look and feel of Excel. You can change data, enter or edit formulas, and apply basic 
formatting if the desktop version of Excel is unavailable.  

§ Use many of the functions that you know from Excel, with IntelliSense lists that appear as you 

begin to type the function name.  

§ Insert and edit tables, format cells, and search for workbook content.  

§ When you change or refresh cell values, see all related workbook elements update, including 

charts, improved conditional formatting, and new features such as Sparklines.  

6 Microsoft Office Web Apps require an appropriate device, Internet connection, supported Safari, Firefox, or Internet Explorer browser, and either 
SharePoint Foundation 2010 for enterprise or, for personal and small business use, a free Windows Live ID to save and access files via SkyDrive. 
There are some differences between the features of Office Web Apps and the Office for Mac 2011 applications. 



 Page 44 

Figure 27 – Easi ly access, create, and save your workbooks no matter where you are through Excel 
Web App. 

§ Stop waiting your turn and co-author instead! You no longer have to worry about someone 

locking you out of a workbook while they edit it. People from different locations can now 
simultaneously edit a workbook at the same time, regardless of which operating system or version 
of Excel they have. They don’t even need to have Excel on their computer. 

§ Work in unison and see changes from others appear in near real-time. The total number of 

authors currently editing the workbook appears in the status bar. Click the author count to 
view the names of all authors editing the workbook as shown in Figure 28. 
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Figure 28 - Break down locat ion barr iers and co-author workbooks in Excel Web App. 

Microsoft Office Web Apps — including Excel Web App, Microsoft Word Web App, Microsoft 
PowerPoint Web App, and Microsoft OneNote® Web App — give you flexible access, a familiar editing 
environment, and a selection of features that you already know to help you get your work done on 
your terms. 

7 Word, Excel, and PowerPoint files can be viewed using Office Web Apps on many devices.  Supported mobile viewers for Office Web Apps on 
SharePoint 2010 include Safari 4 on iPhone 3G and 3GS, Internet Explorer on Windows Mobile 5/6/6.1/6.5, BlackBerry 4.x and later, Nokia S60, 
NetFront 3.4, 3.5 and later, Opera Mobile 8.65 and later, Openwave 6.2, 7.0 and later. Supported mobile viewers for Office Web Apps on 
SkyDrive include Safari 4 on iPhone 3G and 3GS and Internet Explorer 7 on the upcoming Windows Phone 7.  Viewing Excel files via a mobile 
browser is currently only available with Office Web Apps on SharePoint 2010. 

Quick Tips: 

§ Excel Web App makes it easy to share files with people who work on earlier versions of Microsoft Office 
for Mac or Windows, or even with those who don’t have Microsoft Office installed on their computer. 

§ Use Excel Web App to access and view workbooks that you save to a SharePoint 2010 site directly from 
your mobile device.7 
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! Save to SkyDrive 

Free yourself from your desk, get free online storage for accessibility and backup, and make it easier to 
work where you want, when you want and with whom you want. 

§ All it takes is a free Windows Live ID to get 25GB of free online storage for your Office 
documents and photos. And when you store your Office documents on SkyDrive, you can 
access and edit them with Office Web Apps or edit them simultaneously with others in Excel 
Web App. 

§ Now, you can save your Excel Workbooks to SkyDrive directly from Excel 2011. To do this, on 

the File menu point to Share and then click Save to SkyDrive to login with your Windows Live 
ID. 

Figure 29 - Use your free Windows Live ID to save your documents to SkyDrive r ight from Excel 
2011. 

Note: This feature is also available in Word 2011 and PowerPoint 2011. 

Quick Tip: Need a Windows Live ID? Check out 
http://docs.live.com to get started. 

http://docs.live.com
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If you work in an organization that runs SharePoint 2007 or later, you can now save your Excel 
workbooks to your SharePoint sites directly from Excel 2011.  

Saving workbooks to SharePoint gives you easy access to your files and allows you to edit your 
SharePoint workbooks from virtually anywhere. And if your organization runs Office Web Apps, you 
can simultaneously edit those workbooks with others on your team in Excel Web App.  

Saving your workbooks to your SharePoint site helps you work more easily in several ways, such as the 
following: 

§ Keep workbooks accessible to all team members, regardless of where they need to be. 

§ Access and restore workbook versions, and create and manage workflows. 

§ Create team site and libraries to manage content and projects more effectively. 

Figure 30 - Save your 
workbook to SharePoint for 
easy access from virtual ly 
anywhere. 

Note: This feature is also available in Word 2011 and PowerPoint 2011. 
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Insider Tips & Tricks 

Are you the Excel genius of your office, family, or class? Do you support, teach, or create workbooks or 
templates for other Excel users? If you are an Excel power user or just want to explore more of what 
you can do with Excel, check out the insider tips and tricks that follow. 

§ Creating Theme-enabled workbooks 

§ Explore new PivotTable features 

§ Custom VBA Functions 

§ Customize workbooks and save time using Office Open XML 

Creating Theme-enabled workbooks 

Do you want to effortlessly format or reformat your entire workbook and obtain professional-looking 
results in a few simple clicks? In Excel 2011, that’s exactly what you can do when you create theme-
enabled workbooks. Whether you’re an advanced user or just discovering the power of Excel, the 
following tips will help you dramatically reduce your formatting time.  

Want to see themes in action? All of the built-in templates in the Excel Workbook Gallery are theme-
enabled so you can quickly see the advantage of Office themes. To do this, create a new workbook 
using any of the built-in templates and on the Home tab, in the Themes group, click Themes and 
select another theme. Experiment with other themes or use the Fonts or Colors gallery in the 
Themes group and select a combination of different theme elements to create a customized 
workbook theme. 

§ As previously noted in this guide, to create a theme-enabled workbook simply select theme 

elements, shown in Figure 31, as you format your workbooks. 
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Figure 31 - Use the fonts found at the top of the font l ist  that are labeled (Theme Headings) and 
(Theme Body) and use colors found in the Theme Colors sect ion of the color palette.  

Each theme has 10 coordinating colors. When viewing a color palette, the first four colors are for text and 
backgrounds (two dark colors and two light colors), and the additional six colors are for accents. The first 
row provides the main colors for the theme; the additional rows provide five variations of the color, 
starting with the lightest tint and ending with the darkest shade. 

§ To prevent formatting from updating automatically if the theme is changed, for example if the 

border of a cell always needs to be red, use a custom color or those from the Standard Colors 
palette. For fonts, use any font other than those labeled (Theme Headings) or (Theme Body).  

§ The various quick styles available on the Home tab, Format tab, Charts tab, PivotTable tab, and 

SmartArt tab, all shown in Figure 32, automatically coordinate with the colors, fonts, and graphic 
formatting effects of your active workbook theme. Use the quick styles to format an element in a 
few simple clicks and if you change the active theme your formatting will automatically update.  
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Figure 32 – The avai lable quick sty les help you eff ic ient ly format various Excel elements and easi ly 
obtain professional ,  pol ished results .  

§ Office themes also contain graphic formatting effects, such as bevels, shadows, or reflections, which 

can be used to format charts and Office Art, such as SmartArt graphics and other shapes. While 
you can apply these effects manually, you can save time when they’re automatically applied 
through the theme. Start with a theme that uses your desired effects and if you prefer different 
colors or fonts, simply select a different theme color or theme font set to customize the workbook 
theme and make it your own. 

§ To save the combination of colors, fonts, and graphic effects that you apply to your active 

workbook as a custom theme for reuse in other workbooks, on the Home tab, click Themes, and 
then click Save Theme. After your custom Office theme is saved, it will be available in the Themes 
gallery in Excel and also in Word and PowerPoint when you next open these applications. 
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If you want to create an Office theme to share across the Office applications that support themes then it’s 
best to create your theme in PowerPoint 2011. This will ensure other theme elements, such slide masters 
and layouts used in presentations, are accommodated in your Office theme.  

Additionally, you can create custom theme colors in PowerPoint and those colors automatically become 
available to Excel and Word. To do this, in PowerPoint, on the Themes tab, in the Theme Options group, 
click Colors and then click Create Theme Colors. The next time you start Excel or Word, the custom theme 
colors will appear at the top of the Theme Color gallery.  

You can also create your own custom theme fonts and graphic formatting effects. For help getting this 
done, see Customize workbooks and save time using Office Open XML later in this section. 

§ When formatting charts or Office Art, such as SmartArt graphics or other shapes, in the Shape 

Styles gallery you may see gradient and textured fills. These theme fills are used as PowerPoint slide 
backgrounds — making it easy to coordinate all of your Office for Mac 2011 documents. Perform 
the following steps to take a closer look at theme fills: 

1. On the Home tab, in the Themes group, click the Themes gallery, and then click the Folio theme to 
apply it to your workbook. 

2. On the Insert menu, click Shapes, and from the Media Browser, drag a shape to your workbook. 
The shape will automatically be formatted with a textured theme fill. 

3. Select another theme that utilizes theme fills, such as Venture or Breeze, and your shape will 
automatically update to the theme fill used in that theme.  

4. To modify the theme fill, such as change the texture or gradient color, with the shape selected, on 
the Format tab, in the Shape Styles group, expand the Shape Styles gallery and select a different 
shape style. 

Figure 33 - Theme f i l ls  
are avai lable for chart 
elements, SmartArt 
graphics, shapes, and 
other objects across 
Excel ,  Word, and 
PowerPoint 2011. 
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Explore new PivotTable features 

Do you have data you need to summarize? And do you want to summarize that data quickly and with 

minimal effort? Then a PivotTable is exactly what you need. As you may already know, a PivotTable is 
one of the most powerful features in Excel. It enables you to analyze, organize, and summarize a list of 
data using an interactive table, as shown in Figure 34. While a PivotTable may sound complex, the 
PivotTable enhancements in Excel 2011 make PivotTable mastery much easier than you might imagine. 

Figure 34 – Use a PivotTable to easi ly v iew your data from virtual ly any angle. 
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Create a PivotTable automatically  
One simple click is all it takes to create a PivotTable and instantly summarize your data. To see just how 
easy it is to create a PivotTable in Excel 2011, do the following: 

1. On the File menu, click New from Template. In the Excel Workbook Gallery, in the Templates pane, 
select the Business Finance category. Double-click Business Budget to create a new Excel workbook 
based on that template. 

2. Click the Expense Details sheet tab to view the data for your PivotTable. Note the Month, Qtr, and 
Category columns. These three fields can be used to group your PivotTable values or used as a 
report filter to quickly filter your PivotTable.  

3. To create a new PivotTable, place your cell pointer in the list of expenses — selecting the entire 
data range is not necessary. On the Data tab, in the Analysis group, click PivotTable. A new 

worksheet is created and a new PivotTable is added, as shown in Figure 35.  

Figure 35 – Effort less ly 
create a PivotTable in 
one s imple cl ick.  

A PivotTable does not automatically recalculate when the underlying data changes. To refresh your 
PivotTable, place your cell pointer in the PivotTable and on the PivotTable tab, in the Data group, click the 
Refresh button. To refresh only the active PivotTable, click Refresh. To refresh all PivotTables in your 
workbook, click Refresh All.  

You can also refresh a PivotTable each time you open the workbook. To do so, place your cell pointer in 
the PivotTable and on the PivotTable tab, in the Data group, click Options. In the PivotTable Options 
dialog box, click Data, and then click Refresh data when opening file. Note this option must be set for 
each PivotTable in your workbook to refresh all PivotTables each time the workbook opens.  
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Using the new PivotTable Builder 
As you saw in the previous topic, creating a PivotTable is a quick and simple process. It’s just as easy to 
obtain alternate views of your data for further analysis using the new PivotTable Builder, which helps 
you achieve your desired results more intuitively. For example, the previously created PivotTable gives 
you a quick overview of estimated expenses by month and quarter but perhaps you want to see more 
details, such as a breakdown of operating and personnel expenses by month along with each line item. 
To make these changes, use the following steps: 

1. In the PivotTable Builder pane, from the Field name list, drag Category to the Column Labels area, 
and drop it above the Qtr field.  

2. To remove the Qtr field from your PivotTable and show only the operating and personnel 
expenses by month, in the PivotTable Builder pane, in the Column Labels area, drag the Qtr field 
out of the pane and drop it on the worksheet. Note the Qtr field is removed from your PivotTable 

but it’s still available in the Field name list so you can easily add it back at any time.  

F igure 36 – Drag a f ie ld out of the 
PivotTable Bui lder to remove it  from 
your PivotTable. 

3. To add the Line Item field, in the PivotTable Build pane, from the Field name list, drag Line Item to 
the Row Labels area and drop it below the Month field. The modified PivotTable is shown below in 

Figure 37. 
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Figure 37 – Modify your PivotTable in a few easy steps.  

As previously mentioned in this guide, another new PivotTable feature is the ability to expand or collapse 
specific portions of your PivotTable using new drill-down triangles enabling you view only the details you 
want to see. You can experiment with the drill-down triangles on the revised PivotTable you created in 
this topic. Click the arrow next to any month in the PivotTable to collapse the details for that month. Click 
the triangle again to expand the details. Note you can quickly expand or collapse all details for your active 
field with the Expand and Collapse buttons, located on the PivotTable tab in the Field group. 



 Page 56 

  

Enhancing your PivotTable 
Now that you have customized your PivotTable, you may want to enhance it to create a report for 
distribution. These tips will help you turn your PivotTable into a professional, polished report with 
minimal effort.  

§ Use a PivotTable Style to format your entire PivotTable in a few simple clicks. Place your cell pointer 
in your PivotTable and on the PivotTable tab, expand the PivotTable Styles gallery and select a 
light, medium, or dark table style. Note when you use a darker PivotTable Style, your font color will 
automatically switch to a lighter color so your information is easy to read, as shown in Figure 38. 

Figure 38 – Use 
the options in the 
PivotTable Styles 
group to quickly 
format your 
PivotTable. 

You may encounter a time when a PivotTable Style is applied to only portions of your table. This is 
typically caused by manually formatting your PivotTable instead of formatting it through a PivotTable 
Style. You can easily clear all of the formatting so that when you reapply your PivotTable Style it will be 
applied to the entire table. To do so, select your entire PivotTable and on the Home tab, in the Edit 
group, click Clear, and then click Formats. 
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§ Change the number format for your value field. Click the info button  to the right of your value 

field and then click Number to access the Format Cells dialog box. The number format you choose 
will be applied to all of the values for that field.  

§ Make a detailed PivotTable easier to read by enhancing alternating columns or rows. Place your 

cell pointer in your PivotTable and on the PivotTable tab, in the Data group, click Row & Column 
and then click Banded Rows or Banded Columns. Depending on the PivotTable Style you choose, 
alternating rows or columns will be shaded or borders will be added. Note that the PivotTable Style 
gallery will reflect the options you select or deselect under Row & Column so you may want to 
make these selections prior to choosing a PivotTable Style.  

§ Add white space between each PivotTable item. If you have a large PivotTable report with multiple 
fields added to the Row Labels and numerous details displayed, visually breaking up each group 

can help others quickly identify where the groups begin and end. To make this change, on the 
PivotTable tab, in the Design group, click Blanks and then select Insert Blank Line After Each Item.  

§ Experiment with other report options in the Design group, such as Subtotals, Totals, and Layout to 

further customize your PivotTable report to your desired results. 

Custom VBA Functions 

Excel provides you with a large library of functions — perhaps more than you’ll ever actually use in your 
lifetime. While you can tackle almost any needed calculation with those provided, a custom function, 
also called a User Defined Function (UDF), can save you valuable time. Take the following scenario as 

an example: Let’s say you want to give your employees a bonus based on their monthly sales. If they 
meet or exceed $35,000 they’ll get a 25% bonus, $30,000 or more, a 20% bonus, and so on. In your 
workbook that formula would look something like this:  

=IF(A1>=35000,A1*1.25,IF(A1>=30000,A1*1.2,IF(A1>=25000,A1*1.15,IF(A1>=
20000,A1*1.1,A1)))) 

Now consider turning the above formula into a simplified custom function and using the following 
throughout your workbook: 

=CalculateBonus(A1) 
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Both formulas provide the exact same result. Which would you rather construct each time you need the 
formula? If your answer is the simplified version then read on and discover how incredibly easy a 
custom function is to create with a little VBA knowledge. 

Here’s a look at the VBA code for the custom CalculateBonus function: 

Public Function CalculateBonus(InputCell As Double) As Double 
Dim Bonus As Double 
 Select Case InputCell 
  Case Is >= 35000 
   Bonus = 1.25 
  Case Is >= 30000 
   Bonus = 1.2 
  Case Is >= 25000 
   Bonus = 1.15 
  Case Is >= 20000 
   Bonus = 1.1 
  Case Else 
   Bonus = 0 
 End Select 
 CalculateBonus = InputCell * Bonus 
End Function 

Even if you’ve never looked VBA code before you might find it’s actually easier to follow than the 
example worksheet formula that uses four nested IF functions. Here are some tips to help you gain a 
better understanding of what you see in the above code sample. 

§ Select Case in VBA and an IF function are similar. Like an IF function, when a true condition in the 
Case statements is encountered, the code that immediately follows will be executed. The primary 
difference between the two is when you use Select Case you only provide the condition that needs 
to evaluated once, right after the Select Case statement. 

§ If you’re familiar with arguments used in various worksheet functions then you’re already familiar 
with VBA procedure arguments, such as the one you see in the function declaration: (InputCell 

as Double). You use an argument as a placeholder in your function for those values and other 

information you intend to provide when the function is used in your worksheet. 

§ A variable, such as Bonus in the above example, is similar to an argument and an easy way to 

shorten your code. You create variables, or declare them with the Dim statement, to store 

information temporarily and use that information within the procedure. 
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Figure 39 – The VBA Editor provides you with a ful l  range of tools to help you easi ly extend Excel 
funct ional i ty .  

2

§ The as Double data type assignment, shown after the procedure argument, at the end of the 

function, and after the variable declaration, tells the procedure the type of value it can expect, or 
will return to the workbook, in advance. If you don’t explicitly declare a data type then the VBA 
procedure must guess which can lead to unexpected results.  

Ready to give it a try? Follow these steps to create and use the custom function in the example above.  

1. Create a new workbook.  

2. Then turn on the Developer tab to access the VBA tools: On the Excel menu, click Preferences, and 
then click Ribbon. In the Ribbon dialog box, scroll to the bottom of the list of available ribbon tabs, 
select Developer, and then click OK. 

3. On the Developer tab, in the Visual Basic group, click Editor.  

4. On the Insert menu, click Module. Your screen will look similar to Figure 39. 

5. At the top of the Module window, type the code sample provided for the CalculateBonus function. 
Alternatively, if you’re viewing this online you can copy and paste the code in the VBA module. 
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F igure 40 – Create a custom function and use it  throughout your workbook just as you do bui l t- in 
funct ions.  

6. When you are finished typing, on the Excel menu, click Close and Return to Microsoft Excel.  

7. To use your new custom function in your workbook, add some values for your function, and as you 

type the name of your custom function it will appear in the Formula AutoComplete list under User 
Defined Functions, as shown below in Figure 40.  

As you type, watch for the new IntelliSense features, such as Auto List Members, shown here: 

 

Similar to Formula AutoComplete, you can double-click the entry to complete the suggestion or press the 
TAB key when your desired selection is highlighted. 

When you save a workbook that contains macros be sure to change the file format to an Excel Macro-
Enabled Workbook (.xlsm) to preserve your macros. If you save your workbook in the standard Excel 
Workbook file format (.xlsx) your macros will be deleted from the file. 
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That’s all there is to it! You’ve just created your first custom function. Now that you have a taste for 
VBA, here are some resources that provide more in-depth information to help you get started:  

Note: The following resources were written for Excel 2007 and Excel 2010 for Windows, but are equally 
applicable for Excel for Mac 2011. 

§ Getting Started with VBA in Excel 2010 

§ Primer in Excel VBA 

§ Create Custom Functions in Excel 2007 

§ Get in the loop with Excel macros 

§ Watch this: Use macros to automate repetitive tasks 

Customize workbooks and save time using Office Open XML 

With all of the great new features in Excel 2011 and Office for Mac 2011, you never have to leave the 
Office for Mac 2011 programs to create the extraordinary workbooks you’ve always wanted. But, if you 

are an advanced user and you want to see just how far you can take the great content you create with 
Office for Mac 2011, you might want to check out what’s going on under the hood of your workbooks. 

The Office Open XML Formats are the file formats for your Office for Mac 2011 documents and were 
first introduced to Mac Office in Office 2008. A lot of the great functionality that you use in Office for 
Mac 2011 is built using the Office Open XML language — such as document themes and SmartArt. 
And, if you are an advanced Microsoft Office user, you might be amazed at the time you can save and 
the types of customizations you can do when you begin to explore Office Open XML. 

You don’t need to be a developer to learn and use the basics of Office Open XML. In fact, with just a 
few Office Open XML basics under your belt, you can customize formatting and save time on many 
tasks. Consider the following examples: 

§ You can use the Shape feature on the SmartArt Format tab of the ribbon to change the rectangles 
in your SmartArt graphic to ovals. It works great and may be exactly what you need most of the 
time. But when you add a new shape, it’s still a rectangle. Would you like to change that shape in 
the SmartArt layout instead, so that anyone who edits the graphic gets the shape you want them to 
use? All it takes is one simple find and replace in Office Open XML. 

http://msdn.microsoft.com/en-us/library/ee814737.aspx
http://office.microsoft.com/en-us/excel-help/primer-in-excel-vba-HA010351119.aspx
http://office.microsoft.com/en-us/excel-help/create-custom-functions-in-excel-2007-HA010218996.aspx
http://office.microsoft.com/en-us/training/get-in-the-loop-with-excel-macros-RZ001150634.aspx
http://office.microsoft.com/en-us/excel-help/watch-this-use-macros-to-automate-repetitive-tasks-HA010289806.aspx
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§ You are about to hand the courier that important budget when you learn that the client changed 

their logo last week. The logo appears dozens of times in the workbook and the clock is ticking. 
Wouldn’t it be nice if you could paste the new logo once and Excel would place it everywhere it 
needed to be, with formatting and positioning automatically retained? When you understand the 
core Open XML structure of your Excel 2011 workbooks, you can — and you can do it without 
writing a single word of Open XML. 

§ You’re creating a custom theme to apply your own branding to all of your Office 2011 documents. 

You easily create the custom color scheme in PowerPoint. But perhaps you want to use your 
custom font as the theme heading or body font, or you want to customize the effects that are 

applied to graphics in your theme (such as bevels, reflections or gradient fills). You can easily 
customize those things and more using Office Open XML. For example, do the following to create 
your own custom theme font set: 

1. In Excel 2011, on the Home tab, under Theme Options, click Fonts.  

2. Explore the Fonts menu to find the closest built-in font set to the custom font set you need. For 
example, if you want to create theme fonts that use your custom font for headings but Century 
Gothic for the body font, notice that the Apothecary theme already uses the body font you need. 

3. In Finder, browse to: /Applications/Microsoft Office 2011/Office/Media/Office Themes/Theme 
Fonts. Then, copy Apothecary.xml (or whichever theme font set you selected in step 2). 

4. Browse to /Users/[your user name]/Library/Application Support/Microsoft/Office/User 
Templates/My Themes/Theme Fonts and then paste the copied file. 

5. Change the name of the file to the name that you want for your new theme font set. Then, right-
click the file, point to Open With, and then click Other. Select Text Edit and then click Open. 

Depending on which file you open, it may look like one of the two following images. Although they 
look very different, they contain the same required information. 

The file in the screenshot on the left is formatted to show each line individually and contains a number 
of optional pieces of information (font script definitions for use with different languages). The file in the 
screenshot on the right allows the text to run in paragraph format (no line breaks) and contains only 
the required information plus a definition for one font script (Japanese in this case). 
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The required information where you need to make changes is shown with a red underscore in both 
images. This includes the name of the theme font set (the same name that you just gave the copied 
file), the name of the heading font you want to use (called the major font in the XML) and the name of 
the body font you want to use (called the minor font in the XML). Notice that the primary font names 
that you need to change for use with English text (as well as any Latin typeface language) appears in 
the XML tag named a:latin typeface. 

6. Simply change the name of the theme font set at the top of the file, and then change the font 
name for the heading or body font to the font you want to use. Be sure to use the exact font name 
as you see it in the Font lists in Office for Mac 2011 programs.  

Note: If you want to edit, add or remove the font script definitions for other individual 
languages, you can. However, when making any edits in this file (or any XML file) take care not 
to delete or add characters that do not belong. For example, if you accidentally delete just one 

quotation mark or angle bracket while making your edits, the file will not work correctly. If you 
choose to delete font scripts for languages you don’t need, be sure to delete the entire 
associated tag, with its surrounding angle brackets, and nothing else. 

7. Save and close the file. When you next open Excel 2011 (or Word or PowerPoint 2011), you see 
your new font set at the top of the Theme Fonts gallery. 
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These are just a few of many tasks that advanced Office for Mac 2011 users can easily accomplish using 
basic Office Open XML. Explore the resources that follow to help you get started with Office Open XML 
and for the steps you need to accomplish these tasks and more: 

Note: The following resources were written for Office 2007 for Windows, but are equally applicable to the 
tasks discussed here for Office for Mac 2011. 

§ Office Open XML I: Exploring the Open XML File Formats  

§ Office Open XML II: Editing documents in the XML 

§ Using Office Open XML to Customize Document Formatting in the 2007 

Office System 

§ Getting More from Document Themes in the 2007 Office System with Office 

Open XML (if you're new to themes and Office Open XML, read this article 
before the one that follows) 

§ Creating document themes with the Office Open XML Formats 

§ Using Office Open XML to Save Time Without Writing Code 

http://office.microsoft.com/training/training.aspx?AssetID=RC102435331033
http://office.microsoft.com/training/training.aspx?AssetID=RC103570001033
http://msdn.microsoft.com/en-us/library/dd560821.aspx
http://msdn.microsoft.com/en-us/library/dd630117.aspx
http://msdn.microsoft.com/en-us/library/cc964302.aspx
http://msdn.microsoft.com/en-us/library/dd627338.aspx
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Conclusion 
Designed to meet your evolving needs and work styles, Excel 2011 delivers more powerful and 
compatible tools to help you organize and understand information. With Excel 2011, you get a familiar 
user experience in which you can create impactful data analysis and provide professional and easily 

comprehensible visuals of your results. You can also share and work seamlessly with team members on 
a school project, at work, or with other family members and simultaneously on a workbook. In addition, 
Excel 2011 makes it easier for you to access your workbooks anywhere, through a desktop computer or 
your web browser. Excel 2011 helps you get what you need done the way you want it and where you 
want it more quickly, with more flexibility, and with better results. 
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Where to Find It 

Create Incredible Content 

 Features and Benefits Where to Find 
New! Ribbon § The ribbon appears at the top of the screen below 

the Standard toolbar.  

§ To change the ribbon tab order, on the Excel menu, 
click Preferences, and then click ribbon. 

New! Excel Workbook Gallery § On the File menu click New from Template. 

Improved! Paste Special options § On the Home tab, in the Edit group, click the arrow 

next to Paste to display a list of available Paste Special 
options.  

New! Paste as Picture § On the Home tab, in the Edit group, click the arrow 
next to Paste and then click Paste as Picture. 

Improved! Embedded Formula Bar § The formula bar automatically displays above the 
worksheet column headings. 

§ To turn on or off the display of the Formula bar, on 
the View menu click Formula Bar. 

New! Find System § The Find System appears to the right of the Standard 
toolbar.  

New and 
Improved! 

Media Browser § On the View menu, click Media Browser. 

New!  Sparklines § Select the values for your Sparklines (do not include 
data labels) and on the Charts tab, in the Insert 
Sparklines group, click Line, Column or Win/Loss. 

Improved! Conditional Formatting § On the Home tab, in the Format group, click 
Conditional Formatting. 

Improved! Excel Tables § Place your cell pointer in the data range you wish to 

use for your table and on the Tables tab, select a 
table format from the Table Styles gallery.  

Improved! Data Validation § On the Data menu click Data Validation. 
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 Features and Benefits Where to Find 
New! Remove Duplicates § To remove duplicates in an Excel table, on the Tables 

tab, in the Tools group, click Remove Duplicates. 

§ To remove duplicates in any cell range, on the Data 
tab, in the Tools group, click Remove Duplicates. 

Improved! Automatic PivotTable 
creation 

§ Place your cell pointer in the data range you wish use 
for your PivotTable. On the Data tab, in the Analysis 

group, click the arrow next to PivotTable and then 
click Create Automatic PivotTable. 

New! PivotTable Builder § When you create a new PivotTable the PivotTable 
Builder automatically displays.  

§ To display the PivotTable Builder if it has been closed, 

place your cell pointer in a PivotTable and on the 
PivotTable tab, in the View group, click Builder. 

New! PivotTable styles § Place your cell pointer in a PivotTable. The PivotTable 
tab on the ribbon automatically displays. Access the 

PivotTable Style gallery on the PivotTable tab in the 
PivotTable Styles group. 

Improved! Sorting and filtering Do one of the following: 

§ On the Data tab, in the Sort & Filter group, click the 
arrow next to the Sort or Filter command to view 
additional sorting and filtering options. 

§ In any active table or PivotTable, click the arrow  

that appears on row or column headings to access 
the sorting and filtering options. 

New! Search Filter § In any active table or PivotTable, click the arrow  

that appears on row or column headings to access 
the Search Filter.  

Improved! Charts § Select the data range for your chart. On the Charts 
tab, in the Insert Chart group, select a chart type from 
the available chart galleries.  
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 Features and Benefits Where to Find 
Improved! Function accuracy To help distinguish between new and old versions of 

functions: 

§ When using Formula AutoComplete available 
compatibility functions will display under the section 
titled Compatibility Functions. 

New! Function Reference § On the Formulas tab, in the Function group, click 
Reference. 

Improved! Streamlined performance § Experience streamlined performance from the 
moment you launch Excel 2011. 

Improved! Office themes § On Home tab, in the Themes group, click Themes. 

Improved! Cell styles § The Styles gallery is on the Home tab, in the Format 
group.  

New! 32-bit color palette § Display a color palette, such as the Font Color palette 
on the Home tab, and then click More Colors.  

New! Colored sheet tabs § On the Format menu point at Sheet, and then click 
Tab Color. 

Improved! VBA § Access Record and Editor on the Developer tab, in 
the Visual Basic group. 

§ To turn on the Developer tab, on the Excel menu click 
Preferences. In the Preferences dialog box, click 
Ribbon. In the list of ribbon tabs, scroll down and 
select Developer, and then click OK. 

Improved! Help § On the Help menu, select Welcome to Excel for quick 
access to several video tutorials. Or, click Get Started 
with Excel to visit the Office for Mac help site for 

Office 2011, with a range of resources including 
tutorials, videos, and help topics. 

New! Open and Repair § The prompt to repair a damaged or corrupt file 
appears automatically when opening a workbook.  
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 Features and Benefits Where to Find 
New and 
Improved! 

Picture editing tools § The Format Picture tab appears automatically when a 
picture is selected.  

§ Locate Corrections, Recolor, Filters, Remove 
Background, and Crop in the Adjust group. 

To insert a picture, do one of the following: 

§ On the Insert menu point to Photo, and then click 
Photo Browser. 

§ On the View menu click Media Brower, and then click 
Photos. 

Improved! Additional SmartArt graphics § On the SmartArt tab, in the Insert SmartArt Graphic 

group, select a SmartArt layout from the available 
galleries. 

New! Convert to Shapes § Select a SmartArt graphic. On the SmartArt tab, in the 
Reset group, click Convert to Shapes.  

New! Picture compression § On the File menu click Reduce File Size.  

Work more easily with others 

 Features and Benefits Where to Find 
Improved! Sheet protection § On the Review tab, in the Protection group, click 

Sheet. 

Improved! 1900/1904 date system § On the Excel menu, click Preferences and then click 

Calculation. Below Workbook options, select or 
deselect Use the 1904 date system.  

New! Information Rights 
Management 

§ On the Review tab, in the Protection group, click 
Permissions. 

§ Note: Creating IRM-protected documents with Office 
for Mac 2011 requires the volume license edition of 

Office 2011, as well as a Rights Management server 
running Windows Server 2008 R2 SP1. Opening IRM-

protected content to which you have been given 
access can be done from any edition of Office for 
Mac 2011 or from Office for Windows 2003 or later. 
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Work how, when, and where you choose 

 Features and Benefits Where to Find 
New! Access your workbooks on 

the web 

§ For enterprise use: Requires SharePoint Foundation 
2010. 

§ For personal or small business use: Requires a free 
Windows Live ID to save and access files via SkyDrive. 

For co-authoring: 

§ This feature is automatically enabled in Excel Web 

App. To see this feature, save your workbook to a 
SharePoint Foundation 2010 site or a Windows Live 
SkyDrive folder, and then have someone else open 
the workbooks while you are still in it. 

New! Save to SkyDrive § On the File menu point to Share, and then click Save 
to SkyDrive.  

Improved! Save to SharePoint § On the File menu point Share, and then click Save to 
SharePoint. 
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Version Comparison 

☐ Feature\Benefit Included  n Improved þ New 

Create incredible content  

Get easier access to the right tools, at the right time 

 2008 2011 

Ribbon   

The ribbon brings together features formerly 
spread across the Elements gallery and 
Formatting Palette and more to give you a more 
streamlined and flexible work experience. 

 þ 

Paste Special options   

Paste Special options are now at your fingertips 

on the Home tab. Click the arrow next to Paste 
and access several Paste options that were 
previously tucked away in the Paste Special dialog 
box. 

☐ n 

Paste as Picture   

Paste copied content as a picture for quick 
reference or preserve information that should 
remain unchanged.  

 þ 

Excel Workbook Gallery   

The Workbook Gallery offers a variety of new 

built-in templates. You can also access templates 
hosted on microsoft.com and turn to the Excel 
community for inspiration. 

☐ þn 
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 2008 2011 

Embedded Formula Bar   

The embedded Formula Bar now belongs to the 
workbook window and is located closer to your 
work. 

 þ 

Find System   

Search for information in your worksheet or across 
your workbook right from the main Excel window.  

 þ 

Media Browser   

The new Media Browser gives you a more direct 

route to your photos, Clip Art, symbols and 
shapes, along with quick access to your audio and 
movie files.  

☐ þn 

 

Communicate your results more clearly 

 2008 2011 

Sparklines   

Tiny charts that fit within a cell and provide a visual 
summary near its corresponding values. 

 þ 

Conditional Formatting   

Communicate your analysis more clearly through 
improved Conditional Formatting using data bars, 
icon sets, and color scales. 

☐ n 



Page 73 

Powerful and easy-to-use analysis tools 

 2008 2011 

Excel Tables   

Previously known as Excel Lists, tables are now 
easier to create in Excel 2011 and include new 
table styles that enable you to shade alternating 
rows and columns in a few simple clicks.  

n n 

Remove Duplicates   

Use the Remove Duplicates feature to quickly 
generate list of unique values in an Excel table or a 
cell range.  

 þ 

Data Validation   

You can now reference cells on other worksheets 
in your data validation rules.  

☐ n 

PivotTable Builder   

The PivotTable Builder replaces the PivotTable 
Wizard in previous versions and provides a more 

streamlined method for building or modifying 
your PivotTable. Add fields to your PivotTable, 
change the hierarchy, calculation, or number 
format — all from a centralized and more intuitive 
location. 

 þ 
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 2008 2011 

Sorting and filtering   

Now sort and filter on cell color, font color, or 
even cell icons used in conditional formatting. 
New built-in quick filter options have been added 
for specific data types along with multi-select 
filters.  

n n 

Search Filter   

Instantly search available filter options to quickly 
locate and display specific data. 

 þ 

Charts   

Get additional tools for formatting and editing 
charts, including Chart Quick Layouts and 
expanded quick access options for editing many 
chart elements. 

n n 

Function accuracy   

New algorithms and functions have been added 
to help improve over 45 statistical, financial, and 
mathematical functions and to provide increased 
compatibility with Excel 2010 for Windows. 

n n 
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Save time and simplify your work 

 2008 2011 

Office themes   

Select from a wide range of additional Office 
themes to apply fonts, colors, and formatting 
effects to create coordinating, professional results 
throughout your workbooks in just a few clicks. 

þ n 

Cell styles   

New out-of-the box cell styles make formatting a 
breeze. Use the new Styles gallery and obtain 
easy-to-apply and consistent formatting 
throughout your workbook.  

n nþ 

32-bit color palette   

32-bit color palettes are now available to all 
features that support color in Excel 2011. 

þ n 

Colored sheet tabs   

Easily identify worksheets that are related through 

colored sheet tabs. 

 þ 

Visual Basic for Applications (VBA)   

Use VBA, available again across several Office for 
Mac 2011 applications, to save time, automate 
repetitive tasks, and create add-ins for yourself 
and others to use. 

 n 
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 2008 2011 

Help   

Explore a range of videos to help you get started 
with Excel 2011 as well as expanded help 
resources including tutorials, videos, and help 
topics. 

☐ n 

Open and Repair   

If a corrupt or damaged file is encountered, Excel 
2011 will automatically attempt to repair it upon 
opening. 

 þ 

Picture editing tools   

New professional-quality artistic effects as well as 
advanced color, correction, cropping, and 
background removal tools, enable you to edit 
pictures like a pro. 

n þn 

SmartArt graphics   

Create professional-quality diagrams as easily as 
typing a bulleted list. Office for Mac 2011 adds 
dozens of additional SmartArt layouts for even 
more choices to help you convey related ideas 
and non-linear concepts with greater visual 

impact. Additionally, explore improved tools for 
working with picture diagrams and the ability to 
convert SmartArt diagrams to shapes. 

þ n 

Compress pictures   

Reduce file size for easier sharing and portability 
by compressing the images in your workbooks. 

 þ 
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Work more easily with others 

Collaborate on workbooks in new ways 

 2008 2011 

Sheet protection   

Improved sheet protection gives you more control 
over the modifications other users can make and 
enables Mac and Windows users to share 
workbooks more easily. 

☐ n 

1900/1904 date system   

Create more cross-platform compatible 
workbooks by default and copy and paste dates 
between workbooks without worrying about date 

systems.  

n n 

Information Rights Management   

Control access to your sensitive workbooks using 
enterprise-level workbook protection tools.  

Note: Creating IRM-protected documents with Office 
for Mac 2011 requires the volume license edition of 

Office 2011, as well as a Rights Management server 
running Windows Server 2008 R2 SP1. Opening IRM-
protected content to which you have been given access 

can be done from any edition of Office for Mac 2011 or 
from Office for Windows 2003 or later. 

 þ 
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Work how, when, and where you choose 

Access your workbooks virtually anytime, anywhere 

 2008 2011 

Excel Web App   

View and do lightweight editing of your 
workbooks online from virtually any computer 
with a web browser. Or, simultaneously edit the 
same workbook with those in other locations. 

 þ 

Save to SkyDrive    

Save your personal workbooks to a SkyDrive 
folder directly from Excel, using your free 
Windows Live ID. 

 þ 

Save to SharePoint   

Save your workbooks to SharePoint 2007 or later 
directly from within Excel 2011. 

 þ 
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FAQ 

About Excel 2011 

1. What is Excel 2011? 

2. How can I use Excel 2011? 
3. What are some of the major updates to Excel 2011 from earlier versions? 

Excel 2011 System Requirements & Compatibility 

1. Are there special system requirements for running Excel 2011? 
2. Can I open previous versions of Excel workbooks in Excel 2011? 
3. Can I share workbooks created in Excel 2011 with those using previous versions of Excel? 
4. Can I open Excel 2011 workbooks using previous versions of Excel? 

5. Do I need other products in order to use Excel 2011 features? 
6. Which browsers are supported for Excel Web App? 

Using Excel 2011 

1. Does Microsoft offer free training courses or other resources for learning Excel 2011? 
2. Can I customize Excel 2011 based on how I use the product? 
3. Can I access my workbooks when I am away from my primary computer? 
4. How do I access Excel 2011 workbooks from a web browser? 

5. What can I do with my Excel 2011 workbooks in Excel Web App? 
6. How do I edit Excel 2011 workbooks from my iPhone? 

Buying Excel 2011 

1. Which Microsoft Office for Mac 2011 suites will include Excel 2011? 
2. Will Excel 2011 also be available for standalone purchase? 
3. Can I try Excel 2011 before I buy it? 
4. Is there a Windows version of Excel 2011? 
5. Is there a cost for using Excel Web App? 

Excel 2011 Feature-Specific Questions 

1. What is co-authoring in Excel Web App and what are the benefits of using it? 
2. What are the requirements for using co-authoring in Excel 2011? 
3. How does the new co-authoring capability in Excel Web App avoid editing conflicts? 
4. My Sparklines are too small. Can I resize them?  
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About Excel 2011 

1. What is Excel 2011? 

Excel 2011 is our most powerful and compatible release yet. Designed to provide you tools to help 
calculate, manage, or analyze data, and display your results with polished charts and reports, Excel 
2011 helps you create better workbooks in less time and manage them more easily than ever. In 
addition, this release of Excel gives you tools that make it easier than you might imagine to work 
with others on your workbooks or to work when and where you choose.  

2. How can I use Excel 2011? 

Use Excel 2011 to manage your accounting, financial, data analysis, or investment needs in-house. 

Whether it’s your family budget or sales analysis, Excel 2011 can help you do it yourself and save 
time and money. From new features that enable you to quickly sift through and summarize large 
data sets and tools to help you quickly visualize and interpret your data, to displaying your results 
with professional tables, charts, and diagrams, Excel 2011 can help you gain insight into your data 
and make better decisions. 

3. What are some of the major updates to Excel 2011 from earlier versions? 

Excel 2011 includes new and improved features as well as an improved working environment that 
can help you accomplish more tasks, faster.  

§ Simplify how you access the features you need: The ribbon, new in Excel 2011, brings together 
features (formerly located across the Elements gallery, Formatting Palette, etc.) to give you a more 
streamlined and flexible work experience. 

§ Visually analyze your data: With Sparklines, a new feature in Excel 2011, you can create small charts 
in a single cell to quickly discover patterns in your data. It’s a quick and easy way to highlight 
important data trends such as seasonal increases or decreases, saving you time. 

§ Faster and more intuitive sorting and filtering: Now it’s even faster to locate what you need without 
endlessly sifting through large data sets. Select any number of items in your filters without the need 
to use a custom or advanced filter and specify more than 50 sorting levels. 

§ Easily automate complex tasks: Microsoft Visual Basic for Applications (VBA) is back in Office for 
Mac 2011. Extend Excel functionality by recording or creating your own macros. Automate 
repetitive tasks or simplify complex formulas and create your own custom VBA functions.  

§ Work with others without the wait: Excel Web App enables you your colleagues to edit the same 
workbook at the same time through almost any web browser.  
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Excel 2011 System Requirements & Compatibility 

1. Are there special system requirements for running Excel 2011? 

Following are the recommended minimum system requirements for installing and running Office 
for Mac 2011: 

Computer: § A Mac computer with an Intel processor.  

Operating System: § Mac OS X version 10.5.8 or later.  

Memory: § 1 GB or higher recommended. 

Hard Disk: § 2.5 GB of available hard disk space. 

§ HFS+ hard disk format (also known as Mac OS Extended or HFS Plus) 

Web Browser: § Safari 5 or later recommended. 

Installation: § DVD drive or connection to a local area network (if installing over a network). 

Display: § 1280 x 800 or higher resolution monitor. 

Additional requirements 
(may vary based on your 
edition of Office 2011): 

§ Certain online functionality requires a Windows Live ID.  

§ Certain features require Internet access (fees may apply). 

§ Co-authoring and Broadcast Slide Show require Microsoft SharePoint 

Foundation 2010 (for enterprise) or a Windows Live ID (for personal or small 
business use). 

§ Exchange support in Outlook for Mac 2011 requires connectivity to Update 
Rollup 4 for Exchange Server 2007 Service Pack 1 or later. 

§ Access to files stored on a SharePoint site requires connectivity to SharePoint 
2007 or later. 

§ Communicator 2011 requires an account on Microsoft Office 
Communications Server 2007 R2. 

§ The Photos, Audio, and Movies tabs of the Media Browser require 
(respectively) iPhoto 5 or later, iTunes 6 or later, and iMovie 3 or later. 

To obtain system requirements for each Microsoft Office for Mac 2011 suite and standalone 
applications visit the Office for Mac website (http://www.microsoft.com/mac). 

2. Can I open previous versions of Excel workbooks in Excel 2011? 

Yes, you can open files created with Excel 98 or later in Excel 2011. 

http://www.microsoft.com/mac
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3. Can I share workbooks created in Excel 2011 with those using previous versions of 
Excel? 

Yes. If you want to work in the current file format but need to share a workbook with people who 
use Excel 2004 they need to have the Compatibility Pack installed, a free download on the Office 
for Mac website. You can also save your workbook in Excel 97-2004 file format so users that do not 
have the free Compatibility Pack installed can open your file.8 

You can check that the data is compatible with earlier versions of Excel. You can then make the 
necessary changes to avoid the loss of data or fidelity that might occur when that workbook is 
opened in an earlier version. To check for compatibility, on the View menu click Compatibility 
Report. 

4. Can I open Excel 2011 workbooks using previous versions of Excel? 

Yes. If you use Excel 2008 you can open workbooks created in Excel 2011. If you use Excel 2004, 
you can obtain a free Compatibility Pack, available for download on the Office for Mac website 
(http://www.microsoft.com/mac), to open workbooks saved using the Excel 2011 default file 
format.8 

5. Do I need other products in order to use Excel 2011 features? 

You do not need other products in order to use features found in Excel 2011. However, to save a 
workbook to SharePoint you need SharePoint Server 2007 or later. 

6. Which browsers are supported for Excel Web App? 

Supported browsers include Safari 4 or later for Mac, and Firefox 3.5 or later for Windows, Mac, or 
Linux and Windows Internet Explorer 7 or later for Windows. 

Using Excel 2011 

1. Does Microsoft offer free training courses or other resources for learning Excel 2011? 

Yes! There are numerous free, self-help resources on the Office for Mac website. Resources include 
training courses, Help articles, and demos. In addition, you can access the Product Forums to get 
answers from your peers and independent experts in the community, such as the Microsoft Most 
Valuable Professionals. 

 
8 Saving an Excel 2011 workbook to the Excel 97 – 2004 format or editing an Excel 2011 workbook in an earlier version of Excel will limit some 
functionality in the workbook. 

http://microsoft.com/mac
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2. Can I customize Excel 2011 based on how I use the product? 

You can customize many aspects of Excel 2011, including the following: 

§ Customize ribbon tab order. On the Excel menu click Preferences, and then click Ribbon.   

§ Set your preferences for a wide range of workbook and program behavior, ranging from 

controlling formula calculation and setting your editing preferences, to how workbook content 
displays and how to protect your system and help secure your workbooks. All of these settings and 
many more are located in the Excel Preferences dialog box. To do this, on the Excel menu click 
Preferences. 

§ Customize and create your own templates and reusable content. You can customize all formatting 

and layout for your workbooks and worksheet content when you work in Excel 2011. 

§ You can also customize built-in templates, cell, PivotTable, and Excel table styles. It’s easy to make 

your workbooks your own. Access help for all of these features through the Help button on the 
Standard toolbar, or on the Office for Mac website (http://www.microsoft.com/mac). 

3. Can I access my workbooks when I am away from my primary computer? 

Yes. By using Excel Web App, you can save your workbooks online and then access, view, search, 
edit, and share them from virtually any computer with an Internet connection.9 

4. How do I access Excel 2011 workbooks from a web browser? 

Your workbooks can be accessed through almost any web browser using Excel Web App, available 
through Microsoft SharePoint Server 2010 (for enterprise use) or with a free Windows Live ID (for 
personal or small business use). Workbooks look the same in the browser as they do in Excel and 
you can edit your workbooks using the familiar look and feel of Excel 2011. 

5. What can I do with my Excel 2011 workbooks in Excel Web App? 

View your Excel 2011 workbooks with high fidelity, and search for or copy workbook content 
directly from the Excel Web App view mode. In Excel Web App edit mode, use many of the same 
formulas, formatting, and editing features you use every day in Excel 2011, including number and 
font formatting and tools for working with table and filtering options. 

 
9 Microsoft Office Web Apps require an appropriate device, Internet connection, supported Safari, Firefox, or Internet Explorer browser, and either 
SharePoint Foundation 2010 for enterprise or, for personal and small business use, a free Windows Live ID to save and access files via SkyDrive. 
There are some differences between the features of Office Web Apps and the Office 2011 applications. 

http://microsoft.com/mac
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6. How do I edit Excel 2011 workbooks from my iPhone? 

If your workbook is stored on SharePoint 2010 you can use the browser on your iPhone to view, 
but not edit, Excel workbooks. 

Buying Excel 2011 

1. Which Microsoft Office for Mac 2011 suites will include Excel 2011? 

Excel 2011 is included as part of all Office for Mac 2011 suites available for purchase. To view a 
comparison of Microsoft Office for Mac 2011 suites (so you can determine which suite is right for 
you), please visit the Office for Mac website (http://www.microsoft.com/mac). 

2. Will Excel 2011 also be available for standalone purchase? 

Yes. 

3. Can I try Excel 2011 before I buy it? 

Yes. A trial version of Office for Mac 2011 will be available. Visit  
http://www.microsoft.com/mac for more information. 

4. Is there a Windows version of Excel 2011? 

The current version of Excel for Windows is Excel 2010. Excel 2011 provides even greater 
compatibility with Excel 2010 than the previous version of Excel for Mac, and enables you to easily 
share documents with others who work on the Windows platform.  

5. Is there a cost for using Excel Web App? 

No. Individuals can access Office Web Apps on Windows Live, using a free Windows Live ID. 

Additionally, businesses that have a volume license agreement for Office for Mac 2011 have the 
ability to install Office Web Apps on SharePoint 2010 in their organization.  

Excel 2011 Feature-Specific Questions 

1. What is co-authoring in Excel Web App and what are the benefits of using it? 

Co-authoring is an exciting new development in Excel Web App that enables you to simultaneously 
edit the same workbook with others who are working in other locations. You no longer have to 
wait for one person to finish creating or editing their portion of the workbook before you can work 
on it.  

http://microsoft.com/mac
http://microsoft.com/mac
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2. What are the requirements for using co-authoring in Excel 2011? 

Co-authoring is supported in Excel Web App and requires either SharePoint Foundation 2010 or a 
free Windows Live ID. After you save your workbook to SharePoint 2010 or your Windows Live 
SkyDrive, you can open and edit the workbook simultaneously with others in Excel Web App. 

3. How does the new co-authoring capability in Excel Web App avoid editing conflicts? 

Excel Web App does not have a conflict resolution procedure. Instead, if two people are editing the 
same cell at the same time, the retained change will be the last committed edit. 

4. My Sparklines are too small. Can I resize them?  

Since Sparklines fit in a cell you can’t resize them as you would a drawing object or a chart. 
However, along with increasing column width or row height, you can also merge cells in your 
workbook to provide a larger area for your Sparkline display. To merge cells, select the cells you 
wish to merge, and on the Home tab, in the Alignment group, click Merge.  
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Requirements/Disclosures 

Office Web Apps 
Office Web Apps are online companions to Microsoft Office and require the following: 

§ For enterprise businesses and institutions: Requires SharePoint Foundation 2010. 

§ For personal and small business use: Requires a free Windows Live ID. 

§ For use on computers: Supported browsers include Safari 4 or later for Mac, Firefox 3.5 or later 

for Mac, Windows, or Linux, and Windows Internet Explorer 7 or later for Windows 

§ For use on mobile devices: Word, Excel, and PowerPoint files can be viewed using Office Web 

Apps on many devices.  Supported mobile viewers for Office Web Apps on SharePoint 2010 
include Safari 4 on iPhone 3G and 3GS, Internet Explorer on Windows Mobile 5/6/6.1/6.5, 
BlackBerry 4.x and later, Nokia S60, NetFront 3.4, 3.5 and later, Opera Mobile 8.65 and later, 
Openwave 6.2, 7.0 and later. Supported mobile viewers for Office Web Apps on SkyDrive include 
Safari 4 on iPhone 3G, 3GS, and iPad, and Internet Explorer 7 on the upcoming Windows Phone 7.  

Viewing Excel files via a mobile browser is currently only available with Office Web Apps on 
SharePoint 2010. 

Co-authoring 
Co-authoring in Excel Web App is the capability to simultaneously edit the same Excel 2011 workbook 
with other people in different locations. This functionality requires the following: 

§ For enterprise businesses and institutions: Requires SharePoint Foundation 2010. 

§ For personal or small business use: Requires a free Windows Live ID to save and access files 

via SkyDrive. 

This document is provided “as-is.” Information and views expressed in this document, including URL 
and other Internet web site references, may change without notice. You bear the risk of using it.  

Some examples depicted herein are provided for illustration only and are fictitious. No real association 
or connection is intended or should be inferred.  
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This document does not provide you with any legal rights to any intellectual property in any Microsoft 
product. You may copy and use this document for your internal, reference purposes. 

© 2010 Microsoft Corp. All rights reserved. 

Microsoft, Windows, Excel, IntelliSense, Internet Explorer, OneNote, Outlook, PowerPoint, Segoe, 
SharePoint, SkyDrive, SmartArt, Visual Basic, and Windows Live are either registered trademarks or 
trademarks of Microsoft Corporation in the United States and/or other countries.   

iMovie, iPhoto, iTunes and Safari are trademarks of Apple Inc., registered in the U.S. and other 
countries. 

All other trademarks are property of their respective owners. 
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